Elitegroup (ECS) customer support: Buyer beware

I will tell you a story of my experience with Elitegroup‘s (ECS) customer support, a story that starts on New Year’s Eve 2009 and continues today. The point of the story, beyond just venting my spleen that is, is to serve as a note of caution to really look into the support record of any company you may be buying parts from: And, with any luck, the comments may give a fuller picture of support in the graphics card industry, beyond my one case.

In a nutshell, my graphics card failed. ECS sent a replacement, which also failed. Today, Feb 23rd, they are telling me I should wait another 2 months for them to contact China, so ECS may determine whether they will replace the replacement, and get me back on my feet with a working card.

In a little more detail, then:

On Dec 31st, my then 2-year old 8800GT graphics card failed. The failure was not subtle: When the card was connected to power, the PSU would shut down immediately to protect itself. Replace the card with a 9800GT (by BFG in that case), and everything’s fine again. This failure wasn’t entirely unexpected: NVidia has had issues with the manufacturing choices they made, leading to a higher than normal rate of failure, and getting worse when things are powered on and off a lot – like in a desktop PC.

It took ECS 30 days to replace my card. They replaced it with a 9800GTX+, since they didn’t have my model any more. Fair enough. The card they sent me as a replacement was used – refurbished, you might call it – and while it could boot Windows, it failed consistently under load. That load being Hulu on 480p with Flash 10.1 for acceleration, and DDO on maximum details. The card didn’t get any hotter than maybe 75C during these tests. It’d take maybe 5-10 minutes for DDO to show a “black screen”. Now, I had seen this failure before, with my 8800GT: Before it packed in completely, it would show this issue. I underclocked it, and it limped along for another month before giving up the ghost completely. So I had a good idea that what I was looking at was another card failure. I underclocked this 9800GTX+, which helped a little, but did not stabilize it. Over the course of a week, the failures on the underclocked card got more frequent.

So I contacted ECS again, to have the replacement replaced. They asked me to test it on a motherboard with an NVidia chipset: “Since this graphics card is an NVIDIA card then please try an nvidia chipset motherboard to test it on”. I happen to have another system with an NForce4 chipset in the house. What if I hadn’t? What does the motherboard chipset have to do with the graphics card failing?

The card was duly tested on the other system, and the fault followed the card. I got an RMA number and sent the card back to ECS. In the meantime, I installed another 9800GT in my system, this time by PNY. With this card, my system is entirely stable.

When the 9800GTX+ that ECS had sent me as a replacement arrived back at ECS, they started testing it in tech support. Tech support cannot reproduce the failures I am seeing. After days and several phone calls, I am now being told that the card needs to be sent to China for testing, and it may be 2 months before ECS have results from that.

To recap:

– Card is faulty in my system

– Fault follows the card to another system

– My system is stable with another card

I’d say that’s conclusive, even when ECS can’t reproduce in their lab. It may be they run it in an open bench environment, and it’s a lot cooler there than in a tower. After all, if this is related to NVidia’s process issues, thermal does play into it. Or it may be their tests just aren’t as hard on the card as DDO is.

One wonders – at what point is the effort to prove the customer wrong just not worth the effort any more? And why would any company go to great lengths to prove the customer wrong, at any rate?

I’ve asked ECS to escalate this to a supervisor. I have no desire to wait 2 months to then be told by Chinese technicians that they can’t reproduce my fault.

[Update 2010-02-24]

ECS tech support did not have a supervisor call me as I requested. They are now offering me a refurbished 9800GTE. I’m nervous – their previous refurb didn’t do so well. And I decided to take them up on the offer and give it a try. Maybe 3rd time’s the charm.

I have only so many cycles to burn on this. That’s what I’m telling myself, anyhow. Tech support as a process of user attrition – this is a truly miserable experience.

[Update 2010-03-09]

The 9800GTE replacement card is stable in my system. It took a bit over two months to get this RMA done, and more than a fair bit of badgering. All’s well that ends well.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s